Slowness on Flyt PPT

Incident Report for Visma Cloud Services

Resolved

This incident has been resolved.
Posted Jan 13, 2020 - 09:37 CET

Investigating

We are currently investigating this issue.
Posted Jan 13, 2020 - 08:46 CET
This incident affected: Flyt Welfare & Health (Visma Flyt PPT).