Investigating an issue in Visma Net ERP

Incident Report for Visma Cloud Services

Postmortem

We experienced an incident in Visma Net ERP (version 10.32.0) concerning the scheduled processing of invoices. This incident occurred on January 22, between 08:32 and 17:32 CET.

At 08:32, we enabled a feature on our Microsoft SQL servers to improve processing performance.

However, by midday on January 22, we began receiving feedback regarding problems with invoice processing. Specifically, invoices were being sent to Autoinvoice even when they should not have been dispatched based on their status. In response, we stopped all scheduled services to prevent further escalation of the incident.

At 17:32, we disabled the feature that was suspected to be causing the issue, a suspicion that was confirmed during the subsequent investigation over the following days.

Based on our current understanding, these are the typical scenarios where invoices might have been incorrectly processed:

  • Invoices sent to Autoinvoice when they should not have been, due to their status, such as

    • Already sent to Autoinvoice
    • Status marked as 'Balanced'
  • Invoices sent to customers by email when they should not have been, due to their status, such as

    • Already sent to the Customer
    • Status marked as 'Balanced'
Posted Jan 24, 2025 - 16:17 CET

Resolved

Scheduling is started again for all processes. We continue to monitor the status during the day.
Posted Jan 24, 2025 - 08:47 CET

Identified

We have identified the problem and plan to start normal scheduling of tasks tomorrow morning. We are investigating the impact of the incident.
Posted Jan 23, 2025 - 17:32 CET

Update

We are continuing to investigate the issue
Posted Jan 23, 2025 - 15:04 CET

Update

We have now enabled scheduling again for all other functionality except automated sending of invoices. We continue to investigate the issue to find the root cause.
Posted Jan 23, 2025 - 08:56 CET

Update

We are continuing to investigate the issue.
Posted Jan 22, 2025 - 20:29 CET

Update

We are still investigating the issue.
Posted Jan 22, 2025 - 17:57 CET

Update

We can see that the issue is also affecting sending issues by email. We keep investigating.
Posted Jan 22, 2025 - 15:45 CET

Update

We are continuing to investigate this issue. For now until the issue is identified, schedulers are stopped.
Posted Jan 22, 2025 - 14:53 CET

Investigating

We are currently investigating an issue in Visma Net ERP related to sending invoices to AutoInvoice
Posted Jan 22, 2025 - 13:53 CET
This incident affected: Visma Net (Visma Net).