EnterprisePlus Degraded Performance

Incident Report for Visma Cloud Services

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Nov 20, 2025 - 19:43 CET

Investigating

We are currently investigating this issue.
Posted Nov 20, 2025 - 18:22 CET
This incident affected: Enterprise Plus (Enterprise Plus).