EnterprisePlus - Degraded Performance

Incident Report for Visma Cloud Services

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Jul 17, 2026 - 06:17 CEST

Investigating

We are currently investigating this issue.
Posted Jul 16, 2026 - 23:07 CEST
This incident affected: Enterprise Plus (Enterprise Plus).