Delays and timeouts in Maventa

Incident Report for Visma Cloud Services

Monitoring

A fix has been implemented at 12:22 UTC and we are monitoring the situation
Posted May 30, 2026 - 14:48 CEST

Investigating

We are currently experiencing problems in Maventa service, starting Friday 2026-05-29 14:00 UTC and still ongoing. The issues are causing:

- Delays in importing incoming invoices and documents from Peppol
- Delays in sending invoices
- Timeouts on API (especially lookup methods)
- Timeouts on Maventa UI Finder

We are currently investigating these issues.
Posted May 30, 2026 - 13:13 CEST
This incident affects: Common Services (Maventa / Visma .net AutoInvoice).