We are investigating degraded performance on Visma.net ERP
Incident Report for Visma Cloud Services
Postmortem

We identified a problem related to database performance related to heavy load from some customers and parallel requests targeting the same databases. We monitored the environment before applying a fix for the problem. Fix has now been implemented in all databases and we will continue monitoring the performance.

Posted Oct 31, 2022 - 14:30 CET

Resolved
Last night we applied performance improvements on all database servers. We will continue to follow up the status.
Posted Oct 28, 2022 - 09:20 CEST
Update
We will do maintenance related to database performance today evening at 23 CET. Users may experience temporary slowness during this process.
Posted Oct 27, 2022 - 11:33 CEST
Update
We are continuing to work on the database performance improvements during the day. No issues were found yesterday evening related to our improvements.
Posted Oct 26, 2022 - 09:55 CEST
Update
We will continue testing the improvement during tonight and some users may experience temporary slowness in the system.
Posted Oct 25, 2022 - 14:46 CEST
Update
Unfortunately we found an issue with the improvement at the last minute which could have caused issues for our users during the change. We will investigate more and roll out the change when we think that there is no risk for our users.
Posted Oct 25, 2022 - 08:03 CEST
Update
We will do change related to database performance tonight at 23 CET. Some customers may experience slowness during the process but this should be temporary .
Posted Oct 24, 2022 - 14:36 CEST
Update
We have identified a problem related to database performance. We will monitor the environment over the weekend and collect usage data that can be used to verify our solution to the problem. The plan is to roll out the improvement for all customers on Monday evening if no surprises are found in the usage statistics.
Posted Oct 21, 2022 - 09:01 CEST
Identified
We identified a problem that causes slowness and are working on an improvement.
Posted Oct 20, 2022 - 12:43 CEST
Investigating
Some customers are reporting lower performance today. We are investigating the issue and customers may experience temporary slowness during this process during the next 15 minutes.
Posted Oct 20, 2022 - 09:13 CEST
This incident affected: Visma.net ERP (Visma.net ERP).