Visma Net - General slowness

Incident Report for Visma Cloud Services

Update

We are continuing to monitor for any further issues.
Posted Feb 27, 2026 - 16:17 CET

Monitoring

We see now that performance is coming back to normal for most of our customers. We will keep monitoring the situation.
Posted Feb 27, 2026 - 16:17 CET

Identified

Based on investigation we did some changes in the system and recycled some of the servers, That resulted in a positive effect on performance.
Posted Feb 27, 2026 - 16:15 CET

Investigating

We noticed some of our customers experience general slowness using the Visma Net system.
Currently we are investigating the problem.
Posted Feb 27, 2026 - 13:02 CET
This incident affects: Visma Net (Visma Net).