Disturbance towards Telia in Sweden - sms service affected

Incident Report for Visma Cloud Services

Resolved

This incident has been resolved.
Posted May 19, 2023 - 09:22 CEST

Investigating

The provider is investigating with Telia.
Posted Apr 24, 2023 - 12:17 CEST