Investigating an issue in VNI
Incident Report for Visma Cloud Services
Postmortem

The increased number of API calls in the last months added high load on the cache system causing slowness and timeouts (502 Bad Gateway response). As a result we decided to change the application cluster's instance type and scale-out the cluster. The change was completely rolled out during the weekend (6th of April).

This change added higher load on the database causing slowness on query execution which in turn caused failures and downtime for the application.

The database was scaled-up vertically to improve performance and restore normal operations. We're actively monitoring the application. To decrease the load on the database, the development teams will start working on migration of webhooks to the new Visma Webhook Dispatcher service. Also the integration's migration to Visma Connect authentication will help with decreasing the load on the database.

Posted Apr 10, 2024 - 14:49 CEST

Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 10:30 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2024 - 10:30 CEST
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 09:55 CEST
This incident affected: Visma Cloud Platform (Visma.net Integrations).