Challenges in invoice processing and billing

Incident Report for Visma Cloud Services

Resolved

This Issue has been resolved
Posted Feb 27, 2026 - 09:26 CET

Investigating

We are currently experiencing challenges in invoice processing and billing. These issues are intermittent, and Visma is actively working to gain oversight and identify the root cause of the problem.
Posted Feb 26, 2026 - 11:51 CET
This incident affected: Enterprise Plus (Enterprise Plus).