Some Visma net ERP users still experience slowness

Incident Report for Visma Cloud Services

Postmortem

This was related to the earlier incident in cloud providers infrastructure, load was not evenly distributed on our servers.

Posted Jun 26, 2025 - 16:39 CEST

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 11:32 CEST

Update

We are continuing to investigate this issue.
Posted Jun 25, 2025 - 10:07 CEST

Update

This is impacting UI users. It works better with incognito or after clearing the browser session.
Posted Jun 25, 2025 - 10:06 CEST

Investigating

We are currently investigating this issue.
Posted Jun 25, 2025 - 10:05 CEST
This incident affected: Visma Net (Visma Net).