Scheduled maintenance MijnRapportfolio

Scheduled for Apr 30, 09:00 - 13:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 14, 2026 - 14:43 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 14, 2026 - 14:42 CEST

Scheduled

To improve serice and quality there MijnRapportfolio is undergoing scheduled maintenance.
Posted Apr 14, 2026 - 14:36 CEST
This scheduled maintenance affects: MijnRapportfolio.