Enterprise Plus degraded performance

Incident Report for Visma Cloud Services

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Aug 28, 2025 - 09:07 CEST

Investigating

We are currently investigating this issue.
Posted Aug 27, 2025 - 16:37 CEST
This incident affected: Enterprise Plus (Visma Enterprise BI).