Visma net ERP Background API is having lower performance than expected

Incident Report for Visma Cloud Services

Postmortem

Our queueing service for background tasks was not working optimally and was not able to scale according to the load. We improved the mechanism so that scaling is more robust and will scale resources faster according to load.

Posted Apr 26, 2025 - 10:56 CEST

Resolved

The fix for the problem is working and performance is back to normal again. We continue to monitor the service.
Posted Apr 26, 2025 - 10:55 CEST

Monitoring

A fix has been implemented, and we are monitoring the results
Posted Apr 25, 2025 - 15:07 CEST

Update

Testing is still ongoing for this issue.
Posted Apr 25, 2025 - 11:01 CEST

Update

The patch will be released tomorrow morning, as some extra testing is still needed.
Posted Apr 24, 2025 - 17:58 CEST

Identified

The issue has been identified, and a patch is scheduled for deployment later today
Posted Apr 24, 2025 - 15:03 CEST

Investigating

Certain background operations like payments could take longer time than expected.
Posted Apr 24, 2025 - 12:50 CEST
This incident affected: Visma.net ERP neXtGen Services (Visma.net ERP Payment Service) and Visma Net (Visma Net API).