Visma HoP nav pieejams

Incident Report for Visma Cloud Services

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 08:20 CEST

Investigating

We are currently investigating this issue.
Posted Apr 17, 2025 - 08:15 CEST
This incident affected: Visma Horizon, HoP & Numo (Visma HoP).