Scheduled maintenance for Horizon Cloud
Incident Report for Visma Cloud Services
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 21:41 CEST
Monitoring
The scheduled maintenance is currently in progress.
Posted Jun 03, 2020 - 20:39 CEST
This incident affected: Visma Horizon & Visma HoP (Visma Horizon).