Verification is currently underway for the maintenance items.
Posted Sep 13, 2025 - 01:50 CEST
Update
Most of our services are back up and updated, we will do some testing/validation during saturday to make sure the update is running smoothly. Integrations will be down mostly during saturday until we are finished with validation/testing.
We might need to shutdown/restart some of the services during this weekend to fulfill the update.
Posted Sep 13, 2025 - 01:49 CEST
Update
Due to Azure downtimes in Norway East maintenance will take longer than usual. We will continue the update tomorrow in hope of Azure resources being up and running again.
Posted Sep 13, 2025 - 01:11 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 12, 2025 - 18:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 10:35 CEST
Scheduled
We’re performing a major update to Winvoice and underlying infrastructure. During the window, the web app, APIs, and background jobs will be unavailable. This work is to add a lot of new functionality, improve indexing and performance.