Investigating an issue in Visma.net ERP API
Incident Report for Visma Cloud Services
Postmortem

Network team investigation revealed that there was a bug in the Firewall firmware that maps to this specific situation, the case description makes it a rare edge case, but if the clients don't reuse connections and make subsequent connections it could reach a situation where many subsequent connection attempts are dropped.

Firewall has been patched and monitoring shows that no packets are dropped anymore.

Posted Mar 26, 2020 - 09:58 CET

Resolved
Change has been implemented successfully, monitoring shows no downtime. We will continue to monitor the application and the network.
Posted Mar 25, 2020 - 20:25 CET
Update
Network team will soon start implementing the change. We got delayed because we wanted to take all necessary measures to have a smooth fix.
Posted Mar 25, 2020 - 20:07 CET
Update
We are going to implement the Firewall change this evening at 19:00 CET. We do not expect any downtime. We will continue to monitor the application and the network.
Posted Mar 25, 2020 - 15:10 CET
Identified
We have now identified the issue causing API instability. The root cause relates to the firewall and we are working for a fix right now. We will come back later with more details.
Posted Mar 25, 2020 - 11:58 CET
Monitoring
We are monitoring network traffic towards our API. Identifying a root cause for packet loss.
Posted Mar 25, 2020 - 11:24 CET
Investigating
We are currently investigating an issue in Visma.net ERP, some of our customer may experience instability.
Posted Mar 24, 2020 - 16:18 CET
This incident affected: Visma.net ERP (Visma.net ERP API).