Azure server issues Winvoice

Incident Report for Visma Cloud Services

Postmortem

We experienced an outage caused by a zonal issue in Azure Norway East. This affected access to Winvoice between approximately (9/12/2025 01:00) and (9/12/2025 09:00). Service is now restored. After recovery, some customers saw delayed search/index results while our indexing backlog caught up.

We’re conducting a review to reduce the likelihood and impact of similar events. Specifically, we are looking into:

  • Increasing in-region availability by using zone-redundant deployments for our application and data services.
  • Adding a secondary region with failover capabilities so traffic can be routed away from a degraded zone or region.
  • We are ready to migrate indexing to Elasticsearch for faster and more robust indexing meaning that customers will have indexing ready directly at application startup if we needed to reboot.

We’ll share further details as this work progresses. Thank you for your patience, and sorry for the disruption.

Posted Sep 12, 2025 - 10:28 CEST

Resolved

All Issues have now been resolved. Refresh your page if you experience an issue.
Some customers might need to wait for indexing to finnish to be able to see all registries in Winvoice.
Posted Sep 12, 2025 - 10:13 CEST

Monitoring

Azure server issues in Norway East is causing downtime. We hope to be back in a couple of hours.
Posted Sep 12, 2025 - 07:21 CEST
This incident affected: Winvoice.