Investigating slowness in some API endpoints for Visma.net ERP
Incident Report for Visma Cloud Services
Postmortem

The root cause was that earlier during the week a new integration started to make calls towards our API. Calls were not optimal and caused very high load in our environment. We identified the integration and removed the calls and after this API performance was returning back to expected level.

Posted Nov 10, 2023 - 15:07 CET

Resolved
We found an integration that was causing a high load on our API servers. This seems to have caused the slowness. Now the performance should be back to normal again.
Posted Oct 27, 2023 - 07:36 CEST
Update
We are still investigating the slowness in some of our API endpoints. We are currently following up on different scenarios but so far we do not see a significant improvement in performance. We will continue to investigate.
Posted Oct 26, 2023 - 17:04 CEST
Update
We are continuing to investigate this issue.
Posted Oct 26, 2023 - 11:45 CEST
Update
The issue seems to limited to GET operations that are slower than expected. We continue to investigate.
Posted Oct 25, 2023 - 16:28 CEST
Investigating
We are currently investigating this issue.
Posted Oct 25, 2023 - 15:47 CEST
This incident affected: Visma.net ERP (Visma.net ERP API).