Investigating an issue in Business NXT

Incident Report for Visma Cloud Services

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Dec 04, 2025 - 13:31 CET

Monitoring

This issue should now be solved for all customers. We will keep monitoring to ensure high quality.
Posted Dec 04, 2025 - 13:05 CET

Investigating

We are currently investigating an issue in Business NXT. Some users experience longer response times than usual in the application.
We will be back with more information shortly.
Posted Dec 04, 2025 - 13:00 CET
This incident affected: Business NXT (Business NXT ERP).