Investigating an issue in Visma.net ERP
Incident Report for Visma Cloud Services
Postmortem

After release of version 8.17 we found out that when sending invoices to Approval,
the invoice image was not shown, due to an error in the code relating to the invoice attachment
links mapping.
First attempt to fix the code was done on Tuesday evening 12th of November. This did not work as expected and a new fix was made, and deployed on Wednesday 13th of November.
This fix was successful, but still there were some issues left with showing the affected invoice images.
For this, first fix was made on Friday 15th, and last remaining fix was deployed on Tuesday 19th November.

Posted Nov 22, 2019 - 13:03 CET

Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 08:58 CET
Update
The issue is now resolved and the service is up and running as normal.
Posted Nov 22, 2019 - 08:57 CET
Monitoring
Issue is fixed for now. We'll check periodically to be sure that all works as it should.
Posted Nov 19, 2019 - 16:31 CET
Update
Most of the affected invoices are now shown normally. We are still working on some few invoices that was not yet fixed.
Posted Nov 15, 2019 - 13:28 CET
Update
We have now a workaround for invoice images that was affected by the incident. It is now possible to download the image as a zip file. We are still working on displaying the images as usual.
Posted Nov 15, 2019 - 11:32 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2019 - 00:19 CET
Identified
We have now fixed the issue related to showing invoice image in Approval.
It will not fix the documents that were affected by the incident, we will come back during tomorrow with a solution for those.
Posted Nov 14, 2019 - 00:05 CET
Investigating
We are investigating another issue related to showing attachments in Approval.
We are working on a fix, that will be deployed as soon as possible.
Posted Nov 13, 2019 - 11:31 CET
Update
We have now fixed the issue related to showing invoice image in Approval.
It will not fix the documents that were affected by the incident, we will come back during tomorrow with a solution for those.
Posted Nov 12, 2019 - 23:15 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 12, 2019 - 12:40 CET
Identified
We have found an issue with showing invoices in Approval affecting a large amount of customers.
We are working on a fix, that will be deployed as soon as possible.
Posted Nov 12, 2019 - 12:19 CET
This incident affected: Common Services (CS - Visma.net Approval) and Visma.net ERP (Visma.net Financials, Visma.net Logistics, Visma.net Project Accounting).