Investigating an issue in Control Edge

Incident Report for Visma Cloud Services

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 12, 2025 - 10:55 CET

Investigating

We are currently investigating an issue regarding task functionality in Control Edge.
Posted Dec 11, 2025 - 14:55 CET
This incident affects: Control Edge (Control Edge).