Delays in Maventa invoice sending to Finnish and Swedish operators

Incident Report for Visma Cloud Services

Update

We have identified the cause and we are working on solving the issue. We expect the queue to clear up during the afternoon today.
Posted Sep 04, 2025 - 14:00 CEST

Investigating

We are experiencing delays up to 12 hours for sending invoices in Finnish and Swedish operator connections.
Posted Sep 04, 2025 - 13:55 CEST
This incident affects: Common Services (Maventa / Visma .net AutoInvoice).