AML verification no working

Incident Report for Visma Cloud Services

Resolved

This incident has been resolved.
Posted May 04, 2025 - 22:00 CEST

Identified

Customers aren't able to perform AML verification dues issues with AML partner.
Posted May 02, 2025 - 13:07 CEST
This incident affected: inFakt.