Control Edge log in issues

Incident Report for Visma Cloud Services

Investigating

We are informed that some customer are having difficulties to sign in to Control Edge. We are currently investigating this issue.
Posted Apr 28, 2026 - 15:51 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 13:39 CEST

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 13:35 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 23, 2026 - 10:54 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 09:18 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2026 - 11:52 CET

Investigating

Some users are experience issues when trying to sign in to Control Edge and Invoice Manager Admin.
We are currently investigating this issue.
Posted Mar 18, 2026 - 09:23 CET
This incident affects: Control Edge (Control Edge, Invoice Manager).