Monitoring performance issues in Business NXT

Incident Report for Visma Cloud Services

Resolved

Performance was degraded for 30 minutes starting at 13:28 CEST on 2026-04-13.
We are aware of the issue and monitoring the situation, and we will be back with more information if the issue continues.
Posted Apr 13, 2026 - 14:35 CEST