CIR is down
Incident Report for Visma Cloud Services
Resolved
The issue was identified and fixed.
Posted May 12, 2022 - 11:38 CEST
Investigating
We are currently investigating the issue. We'll provide update as soon as possible.
Posted May 12, 2022 - 11:21 CEST