Visma AutoPay - Payments are stuck at "Sending to Bank" status for all Finnish Banks and Handelsbanken Nordic
Incident Report for Visma Cloud Services
Resolved
This incident has been resolved.
Posted Aug 21, 2019 - 16:59 CEST
Investigating
We are currently investigating this issue.
Posted Aug 21, 2019 - 16:05 CEST
This incident affected: Common Services (CS - Visma.net AutoPay).