Investigating an issue in Visma Connect
Incident Report for Visma Cloud Services
Postmortem

On Monday 7th Jan (first normal business day after the public holiday) we had extraordinary constant traffic (double the normal we test for). One of our components (Database Connector) did not cope with this load in one of our APIs.

We were not able to bring the service back to life by scaling it up with a lot more servers or restarting them.

The final solution was to use another Database Connector for handling database-connections of the component that did not scale properly. This development was done in parallel with other activities to bring the service up again. The development took about two hours to complete, deploy and test in the test environment before it was brought to our production environment.

No changes were done to code or the environment between mid-December and Monday 7th of Jan. It was just a matter of double in load compared to previous peaks.

We will test with higher load going forward and continue our efforts in scaling the service.

Posted Jan 09, 2019 - 14:11 CET

Resolved
This incident has been resolved.
Posted Jan 07, 2019 - 11:00 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 07, 2019 - 10:55 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 07, 2019 - 10:52 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 07, 2019 - 10:23 CET
Identified
We are working on fixing the issue. We will keep you posted about the progress.
Posted Jan 07, 2019 - 09:34 CET
Update
We are continuing to investigate the issue and we'll keep you posted.
Posted Jan 07, 2019 - 08:53 CET
Investigating
We are currently investigating a service disruption in Visma Connect. We will provide more information shortly.
Sign in not working for Visma.net, Visma Severa, Visma Online and others
Posted Jan 07, 2019 - 08:34 CET
This incident affected: Visma Severa / Visma Project Management (Visma Severa / Visma Project Management) and Visma Cloud Platform (Visma.net ODP, CP - Visma Online, CP - Visma Connect).