Scheduled maintenance for IPP ODG
Incident Report for Visma Cloud Services
Resolved
The scheduled maintenance is completed.
Posted Mar 17, 2017 - 02:03 CET
Investigating
We will be undergoing scheduled maintenance during 00:00 and 04:00 17.03.2017
Posted Mar 17, 2017 - 00:00 CET