Investigating an issue in Visma.net ERP
Incident Report for Visma Cloud Services
Postmortem

During the last days we have done some changes to database server to improve performance. We have change how scheduled task are run to ease the load on the database servers. We found one code error related to performance that has been released yesterday and fixed the unresponsiveness of the application.

Based on customers feedback we will continue to improve performance by scaling out the database and application servers.

Posted Nov 19, 2019 - 16:58 CET

Resolved
During the day monitoring showed that performance has improved. We consider the incident resolved.
Posted Nov 19, 2019 - 16:49 CET
Update
Monitoring shows that the performance improved. We are continuing to monitor for any further issues.
Posted Nov 19, 2019 - 09:18 CET
Update
The scheduled maintenance has been completed. Fix has been deployed. We are continuing to monitor for any further issues.
Posted Nov 18, 2019 - 22:10 CET
Update
Scheduled maintenance is currently in progress.
Posted Nov 18, 2019 - 22:01 CET
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2019 - 16:17 CET
Update
Test results are good. We will deploy the fix tonight at 22:00 CET.
Posted Nov 18, 2019 - 16:01 CET
Update
Currently we are testing a application fix which we believe will solve the performance issue. We will provide more information soon.
Posted Nov 18, 2019 - 13:44 CET
Update
We are still investigating and monitoring the application. In the meantime we are working to scale out the databases.
Posted Nov 18, 2019 - 10:45 CET
Update
Last night we have increased the memory for our database servers. We have also started to scale out the application today at 10:00 CET. We will continue to closely monitor the application.
Posted Nov 15, 2019 - 10:18 CET
Update
Monitoring show that performance improved. We will continue to monitor the application.
Posted Nov 15, 2019 - 09:16 CET
Update
We have deployed a new fix. Performance should improve. We will continue to monitor the application.
Posted Nov 14, 2019 - 14:12 CET
Update
Some of our customers may experience slowness. We are investigating.
Posted Nov 14, 2019 - 11:49 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2019 - 00:07 CET
Update
Tonight after 2200 CET, we will deploy the fix to improve the performance.
Posted Nov 13, 2019 - 14:41 CET
Update
Until the infrastructure is ready to scale out, to mitigate the performance degradation we are working on another fix. We will provide more information soon.
Posted Nov 13, 2019 - 11:38 CET
Identified
We are working on scaling out the application. We will provide more information as soon the infrastructure is provisioned.
Posted Nov 12, 2019 - 23:37 CET
Update
We are continuing to investigate this issue. In the meantime we are planning also to scale out the application.
Posted Nov 12, 2019 - 11:31 CET
Investigating
We are currently investigating a performance degradation in Visma.net ERP. We will provide more information soon.
Posted Nov 12, 2019 - 11:00 CET
This incident affected: Visma.net ERP (Visma.net ERP, Visma.net ERP API).