Investigating an issue in Visma.net HRM
Incident Report for Visma Cloud Services
Resolved
The issue is now resolved and the service is up and running as normal.
Posted May 18, 2018 - 12:11 CEST
Investigating
We are currently investigating a service disruption in Visma.net HRM. We will provide more information shortly.
Posted May 18, 2018 - 12:08 CEST