Visma Beeple: Eu-West-1 experiencing performance issues/ downtime
Incident Report for Visma Cloud Services
Resolved
On Thursday 11/04 around 12:00 (CEST) an increased query time for a certain set of queries occurred causing degraded performance and unavailability of certain actions.

The root cause was a set of uncached queries that suddenly took a long time as change of query plan by the Database (caused by the normal increase of data usage).

We used a temporary solution by using a different set of queries, that have a small delay in correctness, but will work on a long-term solution where only optimized queries can be used and always be up to date
Posted Apr 11, 2024 - 13:40 CEST
Monitoring
A solution has been found and deployed. We are monitoring the situation further
Posted Apr 11, 2024 - 13:19 CEST
Investigating
an increased query time for a certain set of queries occurred causing degraded performance and unavailability of certain actions.

The root cause was a set of uncached queries that suddenly took a long time as change of query plan by the Database (caused by the normal increase of data usage)
Posted Apr 11, 2024 - 13:02 CEST
This incident affected: Beeple (Beeple EU West 1).